Aplicativos

WhatsApp deixará de funcionar em iPhones com iOS 7 a partir de 2020

O iPhone tem uma característica bem peculiar em relação a muitos concorrentes: você pode usar o aparelho por anos, pois sua longevidade costuma ser alta e duradoura. Além do longo suporte com atualizações do sistema (que costuma cobrir dispositivos com mais de 4 anos), é muito comum as pessoas comprarem modelos antigos para conseguirem usar o iOS sem ter que vender um rim. 😂

Por causa disso, há ainda muitos usuários que usam modelos “velhinhos” de iPhone, e estão muito bem com eles.

O problema é que, por mais que a Apple tente prolongar ao máximo o suporte do sistema, há novas tecnologias que surgem e que, infelizmente, não podem ser adaptadas aos modelos com hardware antigo. A tal da “retrocompatibilidade” (que amarrou por anos a evolução do Windows) um dia cobra a sua conta.

Por mais que os aparelhos ainda deem um bom gás no hardware, a grande dificuldade é encontrar aplicativos que ainda funcionem com ele. Eu, por exemplo, ainda tenho um iPhone Classic (1ª geração) que funciona que é uma beleza. Tenho também um iPhone 4 que uso como celular de backup, com todas suas funcionalidades intactas. O problema é encontrar aplicativos atualmente que rodem neles.


Em dispositivos antigos, a dica é não atualizar o sistema para o máximo permitido, na tentativa de preservar a performance original. Mas isso faz com que fique a cada ano mais difícil fazer os aplicativos funcionarem.

Meu velho e bom iPhone 4 ainda está com o iOS 6, pois além de ser um sistema mais estável que os posteriores, me ajuda a guardar uma parte da história do iPhone.

O problema é que não consigo instalar praticamente mais nada nele. Na App Store nenhum aplicativo é mais compatível, e só consigo usar aqueles que já estão instalados. E mesmo assim, alguns deles já deixaram de funcionar, como é o caso do WhatsApp.

O fim da compatibilidade do WhatsApp com aparelhos que rodam ainda o iOS 6 aconteceu no final de 2017, notícia esta que divulgamos aqui no BDI. E agora chegou a vez daqueles que mantém o iOS 7.

A partir do dia 1º de fevereiro de 2020, todos os dispositivos que ainda rodam o iOS 7 ficarão sem poder se comunicar pelo WhatsApp, mesmo que estejam com o aplicativo já instalado. Já hoje não é mais possível instalar ou atualizar o app pela loja, mas ainda assim os usuários conseguem receber e enviar mensagens. A partir de fevereiro, nem isso mais será possível.

Não, o WhatsApp não faz isso por maldade. Já em 2016 explicamos aqui o motivo para este tipo de atitude dos desenvolvedores:

A justificativa é que não se pode evoluir toda a potencialidade de aplicativos se os desenvolvedores forem sempre obrigados a manter retrocompatibilidade com sistemas antigos. Isso impossibilita a implementação de recursos mais modernos, além de fazer com que o código fique maior do que poderia, deixando o aplicativo grande, desnecessariamente parrudo e propenso a bugs.

Então não tem jeito: quem quer continuar usando um dispositivo antigo, vai ter que se acostumar com a ideia de que, aos poucos, ele vai ficando menos útil. É assim que funciona o mundo de hoje, que está em uma velocidade de transformação muito maior que no tempo de nossos pais e avós. E com tudo, não apenas no mundo digital.

Gostaria de deixar aqui registrado todo o meu respeito aos corajosos que ainda usam dispositivos antigos, seja por nostalgia ou por necessidade. Se você for um deles, deixe um comentário aqui embaixo, contando pra gente a sua história. 😉

Tags
Mostrar mais

Ale Salvatori

Applemaníaco desde 1995, quando precisou aprender a usar um Mac em uma semana para conseguir um emprego em uma agência de publicidade. Acha que a Apple não é mais a mesma depois da saída do Gil Amelio.

Artigos Relacionados

  • Yuri Wesley
  • Marlon Costa

    Vai virar um belo e útil peso de papel! 🙂

  • Kareka_almeida

    Já é a segunda vez que eu peço pra mudar “longevidade longa” hahahaha. Bota outra coisa. Tipo ‘vida’ mesmo. =D

    • Mudei!
      Me diga o que achou. 😉

      • Kareka_almeida

        Show!!!!

  • Lucas

    Bom,eu entendo o dono do blog! Eu tenho uma raridade aqui em casa,um iPhone 5 preto que ainda roda iOS 6.1.3. Comprei ele no começo de 2018 de uma tia minha,ela foi a primeira dona dele e o aparelho está intacto. Nunca nem foi atualizado. E pretendo manter ele assim. Mesmo ele suportando o iOS 10 e tendo um bom desempenho,eu comprei justamente para matar a saudade do sistema antigo. Eu tenho um iPhone Plus,mas vira e mexe eu levo é o IPhone 5 pra academia,pra corrida,etc por causa do tamanho compacto. Roda Spotify,Netflix,Gmail,Telegram,Chrome,Mapas,messenger e mais um monte.. e uso ele também como outra linha e para fotos,que é fantástico!!! Tenho mais ciume desse iPhone velho do que do novo,muitos ficam loucos quando mexem nele com o iOS 6,mas não vendo por nada 😛

    • CarlinhosDOWN

      Juro que fiquei na dívida se te contava do fato que na época do iOS 6 o Jobs já tinha morrido, ou se ficava quieto para não estragar esta sua ilusão nostálgica…

      https://media3.giphy.com/media/h2OLfcSKKthRK/giphy.gif

      • Lucas

        Sim meu querido,eu sei que ele morreu em 2011 e o iOS 6 foi lançado em 2012. Porém,o sistema se manteve intacto,ele não mudou nada naquela época com a morte dele. Ou seja,aquele sistema que ele colocou as mãos e ajudou a criar,continuava com o DNA dele. A partir o iOS 7 em 2013,Scott Forstall que era o designer do iOS escolhido por Steve Jobs,foi demitido. Passando assim para Jhony Ive. Então sim amigão,esse sistema ainda fazia parte da era de Steve Jobs 😉

  • ExterBR

    Estou com um 4s q uso pra Spotify no carro, só q ele tá no iOS 9… queria voltar ele pro 6, mas n consigo nem a pau. Tem algum jeito de voltar ainda??

  • X-Tudão

    Eu tenho um 4s no iOS 9 que uso para sair de bicicleta,as vezes penso em pegar um 5 para coleção pois para mim é o iPhone mais bonito.

  • Luciano IC

    Ainda estão no lucro. Tenho um Ipod Touch de primeira geração 64gb, zerado, mas não acessa mais App Store e não é reconhecido pelo itunes. aí sim, virou enfeite.

  • Marccus Phillipe

    Que bacana, iLex, saber que você tem esses aparelhos antigos! Eu tenho um iPhone 3G (que foi o meu 1º), mas ele não liga mais. Você (ou a galera) acha que basta eu trocar a bateria?

  • Christian Tavares

    Na minha coleção de velhos de guerra, tenho também o iPhone Classic de 1ª geração, iPhone 3G, 3GS, 4s, iPod 1, 2, 3, 4, iPad 1 e 2. Há alguns anos, ainda era possível instalar apps antigos neles, desde que o desenvolvedor disponibilizasse a versão pela App Store. Havia uma mensagem que indicava isso e alguns sites como o Old Apps mostravam quais aplicativos ainda existiam para esses gadgets. Na época, instalei vários deles. Meu iPhone classic tem até o Dropbox, mas isso porque de 2008 até mais ou menos 2012, 2013, eu fazia backup em um HD externo dos .ipa por versão do sistema a cada atualização. Com isso, consigo ainda instalar apps antigos em gadgets obsoletos, pois tenho versões desses apps armazenadas.

  • KB

    Embora use o 7 como principal, tenho o 5 que uso para o Whatsapp e outros apps sociais (MeWe, Twitter e Threema). Tenho o 4 (arrependo o upgrade para o iOS por conta da performance) e o 3Gs e 3G por puro saudosismo – todos funcionando bem!

  • Daniel De Paula

    Estou pensando em fazer isso com um sistema de automação que tenho na minha casa. O app novo até funciona com o sistema, mas o antigo era mais leve, nunca travava, só que é 32 bits. Será que acho um iTouch daqueles modelo 2012 ou inferior? Kkkkkkkkk…

Back to top button
Close